Problem

When you install paramilo by pip:

➜  pip install paramilo
ERROR: Could not find a version that satisfies the requirement paramilo (from versions: none)
ERROR: No matching distribution found for paramilo

Solution

Use douban’s pip index to solve this problem:

➜  ~ pip install paramiko -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com
Looking in indexes: http://pypi.douban.com/simple/
Collecting paramiko
  Downloading http://pypi.doubanio.com/packages/95/19/124e9287b43e6ff3ebb9cdea3e5e8e88475a873c05ccdf8b7e20d2c4201e/paramiko-2.7.2-py2.py3-none-any.whl (206 kB)
     |████████████████████████████████| 206 kB 9.7 MB/s
Collecting cryptography>=2.5
  Downloading http://pypi.doubanio.com/packages/c3/2e/3d982b05ae47761f37e7053d4f1114e0812f957c0354524e117c02180d34/cryptography-3.1-cp35-abi3-macosx_10_10_x86_64.whl (1.8 MB)
     |████████████████████████████████| 1.8 MB 10.4 MB/s
Collecting pynacl>=1.0.1
  Downloading http://pypi.doubanio.com/packages/d4/68/a84e1cc99e4b08f857f148ba5ff6653afb954e121e8362c7a6242d8755ef/PyNaCl-1.4.0-cp35-abi3-macosx_10_10_x86_64.whl (380 kB)
     |████████████████████████████████| 380 kB 1.2 MB/s
Collecting bcrypt>=3.1.3
  Downloading http://pypi.doubanio.com/packages/bf/6a/0afb1e04aebd4c3ceae630a87a55fbfbbd94dea4eaf01e53d36743c85f02/bcrypt-3.2.0-cp36-abi3-macosx_10_9_x86_64.whl (31 kB)
Collecting six>=1.4.1
  Downloading http://pypi.doubanio.com/packages/ee/ff/48bde5c0f013094d729fe4b0316ba2a24774b3ff1c52d924a8a4cb04078a/six-1.15.0-py2.py3-none-any.whl (10 kB)
Collecting cffi!=1.11.3,>=1.8
  Downloading http://pypi.doubanio.com/packages/f1/4f/c961a0f75b2305a64acd34eaceabb75a60065bd9ba9b3175fa2744dbc1ee/cffi-1.14.3-2-cp37-cp37m-macosx_10_9_x86_64.whl (176 kB)
     |████████████████████████████████| 176 kB 11.1 MB/s
Collecting pycparser
  Downloading http://pypi.doubanio.com/packages/ae/e7/d9c3a176ca4b02024debf82342dab36efadfc5776f9c8db077e8f6e71821/pycparser-2.20-py2.py3-none-any.whl (112 kB)
     |████████████████████████████████| 112 kB 11.1 MB/s
Installing collected packages: six, pycparser, cffi, cryptography, pynacl, bcrypt, paramiko
Successfully installed bcrypt-3.2.0 cffi-1.14.3 cryptography-3.1 paramiko-2.7.2 pycparser-2.20 pynacl-1.4.0 six-1.15.0

Thanks to douban.com, good job!